Posted Wed, 22 Jan 2014 11:57:24 GMT by JakubVajda

I want to ask if anyone has experience of creating, loading and editing selection.

We created a new selection in MOUSE module (MU 2012) consisting only from msm_Node elements. Later we load this selection and we want to remove some nodes from it.

And now the fun begins:
It is not possible to change any part/element of the selection, it is only possible to add some.

I went through "Set selectable layers" dialog, checked the MOUSE nodes layer to be sure it is selectable. Nothing happened, still the same result.
Then i try to look into Selections and SelectedObjects tables in the database, there were some records, so I deleted all those records, thinking that the new selection shoud add here the new MUIDs, but this is not true.

So please, can you advice how to remove from selection certain parts?
I know everything about selection was good in all previous versions till 2011, but now I can't deal with it.
Posted Sat, 25 Jan 2014 16:21:58 GMT by Thomas Telegdy
If the GUI of MIKE URBAN doesn't work, you may try to edit the selection file *.mus in a text editor. The *.mus is essentially a list of MUIDs, with additional headers for the type of model element. For a reasonable number of elements, search and delete should be fast enough. To finish you load the modified *.mus.
Posted Mon, 03 Feb 2014 12:12:49 GMT by JakubVajda
Obviously you can search them in text content and delete them manualy, but the point is you are representing this selection graphicaly and you want to work with this selection also graphically, otherwise you are not 100% sure what selected features you have. Especially if you work with 1000+ elements!

I see here only possibility to save another selection (eg the one you dont want  to be selected) and subtract it matematically (or by sql or whatever).

But this is not fast enough to work with it.

So the conclusion could be:
[quote]Eventhough there is advanced possibility of modifying selections - do not use the save and load selection, because you can't then modify any part of this selection, unless you modify it manulay in text mode.[/quote]
Am I right?
By the way, this same buggy behaviour is happening on version 2014.
Posted Wed, 19 Feb 2014 13:51:23 GMT by Thomas Telegdy
Hm, sounds like a software issue, and then it ought to be registered and solved! Have you contacted MIKE by DHI support?
Posted Thu, 10 Sep 2015 15:25:36 GMT by Brian Brenhaug Enterprise Water Systems Team Manager
Happens pretty frequently to me too. Usually it's with large selections. Saving seems to still work, so sometimes I have luck saving back to an MUS and reloading it after clearing or restarting Mike Urban. Another work around I use pretty frequently is to just work with the feature sets in ArcGIS instead as it's selection capabilities are more robust.
Posted Wed, 14 Oct 2015 18:43:02 GMT by Marcus Richter
Hi Jakub,
working on a 25k+ pipe network and I am not able to reproduce the described behavior...
Having said that, I am working on 2016 beta.
Would be interesting to see if the problem still exists after you have upgraded to 2016. Alternatively please feel free to contact support, ideally (if possible) send the model as well.
best regards...

Posted Wed, 04 Nov 2015 14:01:02 GMT by JakubVajda
@Marcus: thank you for good news! Looking forward to try 2k16..

@ThomasT: Yes, I contacted support, it is registered as an issue.

You must be signed in to post in this forum.