• Precipitation and free outflow boundary condition in MIKE 21 FM

    Hey there,

    has anyone of you succesfully used the free outflow boundary condition while simulating precipitation in MIKE 21 FM? I think it was first introduced in MIKE 2019.
    When I use this boundary condition my models usually shows blow ups, hundreds of CFL-Errors etc. while the model runs ok when using a land boundary.

    Quote from the manual:
    [quote]The free outflow condition is typically used at downstream boundaries where the water is flowing out of the model. In case of water flowing into the model domain the simulation may become unstable.[/quote]

    What means "(...) in case of water flowing into the model (...)"?

    Thanks

  • Re: DHI matlab toolbox

    Hey Ayla,

    which MIKE Version do you use?
    which MATLAB Version do you use?
    Which Version of the Toolbox do you use?

    What does your code look like?
    What kind of error message do you get?

    You need to provide some information to be able to help you.

  • Re: Displaying Velocity for each node.

    [quote]

    I actually do have a copy of an academic version of MATLAB, would this be sufficient enough to run the DHI MATLAB TOOLBOX?
    [/quote]

    I don't really know, sorry. Give it a try :-).
    [quote]
    Also tried googling the said toolbox and found a Github page for DHI, is this where I should be able to get all the necessary info?
    [/quote]
    Yes, exactly: https://github.com/DHI/DHI-MATLAB-Toolbox
    Note, that there is a short UserGuide: https://github.com/DHI/DHI-MATLAB-Toolbox/blob/master/Documentation/DHI_MATLAB_Toolbox_User_Guide.pdf
    On page 15 it says, that there is an approach to interpolate element center values to the node positions.

    Greetings
    Sebastian
  • Re: Displaying Velocity for each node.

    Hey,

    [quote author=bakjee link=topic=21986.msg29063#msg29063 date=1592366027]

    I was hoping to display the velocity at each time step for all the nodes in my domain, something that might look like the image in the attatchment. I have a feeling that this could be the with the result viewer tool but have no clue how this can be achieved?

    (...)

    Edit:

    So, im not sure if this is the correct way however but I converted dfsu to a reasonably sized grid files where I can kinda achieve what I wanted to do in the tabular view but i'm guessing there is an easier and more appropriate way. Also converting into grid files takes very long and a lot of computing powers...
    [/quote]

    I think your solution is one way to go, but as you mentioned it doesn't show the velocity at the nodes. As far as i know, there is no build-in function to achieve this, since MIKE21FM uses an Finite Volume approach, which means that the values are calculated at the center of the mesh elements. In case you have Matlab you can check the DHI-Matlab-Toolbox.

    Another way is MIKE2SHP (Mike Zero Toolbox), which converts the dfsu-file to a shapefile. But due to the the Finite Volume Approach and the way MIKE2SHP works, the result only shows the velocity for each element and not at the nodes.

    Greetings,
    Sebastian
  • Re: Creating .dfs2 file from .asc file

    Hey,

    [quote author=jkurzweil link=topic=21985.msg29062#msg29062 date=1592321794]
    For what ever reason when I create the .dfs2 file using the grid2mike tool box, it does not really give the file all that it needs, specifically it does not give it an item. Maybe I am just doing it wrong, so if someone knows something I don't please let me know. To fix this I opened the created .dfs2 file directly from my explorer. This opens the file in a MIKE zero editor. I hit edit->items, then under type I selected elevation for type and meter for unit.
    [/quote]

    As far as i know, thats the "normal" way to do this. The reason is, that MIKE simply doesn't know what kind of data the values of the asc-file represent. Im using asc-Files and Grid2Mike to import spatially distributed rain patterns, so the item should be precipitation height rather than elevation or anything else.

    Greetings,
    Sebastian
  • Contour Visualization of MIKE 21 FM results

    Hello,

    I have a question about visualizing the results of flood simulations with MIKE 21 FM.
    Looking at the maximum water depth in Mike Zero the mesh elements are often not completely wetted with water due to the elevation of the mesh, especially at the edges of the flooding area. The results in Mike Zero show the contours.
    For the processing of the results the results usually have to be available in a GIS. Using Mike2Shp leads to results where each element gets only one height, which is an erroneous and unsightly presentation of the results.
    How can one achieve a comparable representation in Arc(GIS) similar to the contour visualization as in Mike Zero based on the MIKE 21 FM results?

    Many thanks and greetings
    Sebastian
  • Re: Create *.dfsu file for new grid from old .dfsu file

    Hey Chris,

    I'm not sure if i understand your question correctly.

    But you could convert the .dfsu bed roughness file to a .dfs2 file and use this file as input for MIKE 21 FM (MIKE Zero -> File -> New -> File ... -> MIKE Zero --> Grid Series (.dfs3,.dfs2, ...) --> From dfsu File.

  • Re: NO ELEMENT IN SELECTED AREA WARNING

    Hey Simon,

    just a guess:
    If you select the "Geographic View" Tab in the Output Menu in MIKE 21, do you see some sort of "fishnet" on top of your model domain? If not, i guess that the coordinates of your area output do not fit your model domain. This might happen, if you "reuse" an old *.m21/*.m21fm-File and you change the model domain (e.g. the extent). The coordinates in the "Output specification" Tab do not change automatically and need to be changed to fit the new model domain.

    Hope this helps!
  • Re: PROGRAM MULTIPLE SIMULATIONS

    Hey,

    check this:
    https://forum.mikepoweredbydhi.com/index.php/topic,1592.0.html
    and
    https://faq.dhigroup.com/default.asp?module=MIKE+21&ID=57#answer

    Hope it helps!
  • Re: How to import river network and cross section data from Arcmap?

    Hi,

    I haven't really worked with MIKE11 so i just know some sort of workaround. Do you have MIKE HYDRO? In this case you can add Shapefiles as Background Layers and afterwards open the menu Tools > Auto generate Cross Sections and choose "Survey points from shape file". Now you can select the shapefile you added as Background Layer in the step before. The cross section shapefile should be a point shapefile with a field that defines which survey point belongs to which cross section number.

    The river network can be imported in MIKE HYDRO by File > Import from shape file and then choose "Branches".

    Hope this helps!