Posted Tue, 09 Jan 2018 14:45:44 GMT by christianleprince
Good day

Can you please assist me with the following error?

So I have realised that an object that I have declared in the model editor as state and written equations with it, was not appearing in the desktop app when runnning simulations.
I then decided to move it into the interface and adjusted the relevant equations accordingly(that is replacing all the equations with interface...).
When I check the instance in the model editor, it tells me that the file could not be found and that I need to modify the Instance property 'ModelLib' ( I have attached a picture), of which I don't understand.

Thank you in advance.
Posted Tue, 09 Jan 2018 18:24:50 GMT by Enrico Remigi WEST Product Owner
it's difficult to say by just looking at the (synthetic) error message exposed in the pop-up. There may be some more details in the actual Logging - you may have a look yourself, or send it over.
In any case, irrespective of what you did (if you correctly replaced interface. by state. that should be enough), what should be investigated further is:
[list type=decimal]
[li]why did you not get to see the state variable that you declared? This would certainly not be solved by just changing the variable from state to interface ...[/li]
[li]why does it now complain about a missing file? If a file cannot be found, then there's no point in even attempting to open a project based on that library ...[/li]

In order to provide you with a more sensible answer, can you please explain in some detail what were you attempting to do and perhaps even attach a code sample?
If this should not be enough, I might then ask you to contact our tech support and provide a number of key files.
Posted Wed, 10 Jan 2018 11:43:56 GMT by christianleprince

I looked at the Logging panel but there was no specific problem highlighted (I have attached a picture).

1. I am not sure why is not appearing actually. That's why I thought putting it into the interface will make work, but it is not working as you pointed out.

2. It is also bizzare that it is compaining about a missing file now. And as soon as i cancel that operation, the instance check remains successful. But i checked that the assumed missing file is actually in the library.

I was writing a code for a primary settling tank model in PWM_SA. That's where I noticed that the state variable influent flow rate that was declared was not reflecting in the simulation environment, unlike the other state variables (effluent flow rate, actual underflow rate) which were all put in the group 'operational'.
Find attached a code sample as requested.
Posted Wed, 10 Jan 2018 14:42:31 GMT by Enrico Remigi WEST Product Owner

The limited snapshot of the Logging that you have attached is not sufficient: there may be more information in the lines further up in the file.
It's best to save the Logging as Excel spreadsheet (Save button in the Logging pane).

The .msl file is also insufficient to test your code because it refers to (#include) two files (namely, UCTPST/wwtp.pst.uct.msl and UCTPST/wwtp.VolumeUCTPSTConversionModel.body.msl) that are not provided here.
I have tried commenting those #include statements out and focused on the two remaining classes, BasePST and PSTConversionModel: the Instance check (in the [b]WEST 2017[/b] Model Editor) fails due to "Undefined type name "UCTPSTIndexOfSolvent".
Why do you even use a "UCTPST" IndexOfSolvent? This kind of identifier is usually auto-generated by prepending the Instance name (e.g. ASM1) to the "IndexOf" followed by the name of a Group (within a Category).
Have you created a new Instance called UCTPST ? If so, it should definitely be able to find the definition, unless you did not generate the code ...
If not, you may have manually renamed an IndexOfSolvent in a piece of code that you copy-pasted from an existing class? in which case of course it would not work ..

In order to help you out, I really need to entire library - or, if you are implementing this code on top of a reference library, e.g. rel.2017, all the files that you have added.
Please send all this to [b]Technical Support[/b].

One more thing: I am surprised when you say that the Model Editor did not issue any error message. What version of WEST (and Model Editor) are you using?
Posted Fri, 26 Jan 2018 07:30:45 GMT by christianleprince

I have actually created a new category called UCTPST, that is similar to the UCTAD category in the PWM_SA instance.

I don't understand as well why was there no error mentioned by the model Editor. I am using WEST (and Model Editor) 2016.

I have sent the whole library to the technical support as requested.


You must be signed in to post in this forum.