Posted Mon, 05 Mar 2018 05:03:16 GMT by Dipen Saha
Hello there,
I am operating a 1D drainage model for south west region of Bangladesh. I am getting "Floating point division by zero" error during simulation. If anybody knows the solution please help me out! thank you in advance.
Posted Thu, 08 Mar 2018 03:27:51 GMT by Aurelian

Can you give us more details about the model and the context of the error ? What modules of Mike 11 are activated in the model ? When do the errors occur? Can you attach a print-screen of the error ?

Kind regards,
Posted Sun, 11 Mar 2018 10:17:38 GMT by Dipen Saha
Dear Aurelian,
Thanks for your reply. I am using hydrodynamic module of MIKE11. After a certain time during simulation it shows that error. screenshot is attached for you. please feel free for further quarries if you need.
Thank you and BR
Posted Thu, 15 Mar 2018 15:47:18 GMT by Aurelian
Dear Dipen,

Thank you for the print screen. Apparently, the problem is generated by the instability of the model. I observed that you have many warnings which indicate strong oscillation in the model. My opinion is that the eror "Floating point division by zero" is just a consequence of the instabilities.

1. Analyse the results file (it should cover 67% of simulation period) and try to identify the problems here;
1. Check out the geometry of the cross sections and the junctions between branches;
2. Try smaller time steps for simulation: 1 min, 30 sec, even 5 sec;

Best regrds,

Posted Thu, 28 Jun 2018 11:58:46 GMT by Nguyen Triet
Dear Dipen,

have you solved your issue? If yes, I would love hear about your solution.

best regards,

Posted Thu, 28 Jun 2018 12:04:10 GMT by Nguyen Triet
Dear Aurelian,

could you elaborate more on your second recommendation: "Check out the geometry of the cross sections and the junctions between branches"? Does it mean to equal the "lowest point", i.e No. 2 in makers of cross-sections at the junctions? Thank you!

best regards,

Posted Wed, 09 Mar 2022 09:24:40 GMT by Dipen Saha
Sorry for late reply! The problem was in control structure. I've changed the control strategy and It worked. That's it. Thanks Khanhtriet and Aurelian!

You must be signed in to post in this forum.