Posted Sun, 03 Jan 2016 04:52:00 GMT by Craig Goodier Principal Engineer
Here's my situation:
I have license for MikeFlood, but not MikeUrban.
In order to use output from MikeFlood dfs2 file in Arcmap, one needs to install MikeUrban.
This worked fine for Arcmap 10.1, and DHI 2014 products.

I have now upgraded to DHI 2016 and Arcmap 10.3.1.

Order to install was:
Uninstall Arcmap 10.1
Uninstall MikeZero2014
Uninstall MikeUrban2014

(All ok so far)

Install Arcmap 10.3.1
Install MikeZero2016
Install MikeUrban2016

Installation went ok, but the problem arises that I can't open any Arcmap mxd any more, if they have any reference to a dfs2 file.
When trying to open an mxd with Arcmap 10.3.1, I just get the error window with "Serious problem, do you want to send error report to ESRI, etc." so Arcmap never opens.

I tried MXD Doctor, no help.
I tried copying all layers into new mxd, no help.
I opened MXD on a different computer that didn't have any DHI products, and it opened fine.

Back to my computer, I tried uninstalling MikeUrban2016, and then Arcmap 10.3.1 would open, but of course, any reference to a dfs2 file had the red exclamation mark and was not valid.

Has anyone experienced similar problems, or come up with any solutions?  Has there been a change in how Arcmap can read dfs2 files?

Posted Wed, 06 Jan 2016 00:47:00 GMT by Craig Goodier Principal Engineer
If anyone else has this problem, I've just been informed it is a bug in the 2016 release of DHI products, in relation to Arcmap 10.3.1
Posted Tue, 26 Jan 2016 19:31:00 GMT by Craig Goodier Principal Engineer
DHI have released MikeUrban2016 Service Pack 1.  This SP has the fix for the above problem.  Arcmap 10.3.1 can now display dfs2 files (if you install MikeUrban 2016 and SP1).

You must be signed in to post in this forum.