Posted Tue, 17 Jul 2018 15:12:11 GMT by Matteo Baralis

I am building a 3D model of a Borehole Heat Exchanger that crosses 3 geological units (out of which two are aquifers). The BHE should run with a time-varying heating load with annual cicles. Thus it has been modelled with imposed Power and flow rate (in terms of time series, linearly varying).

As the simulation starts, it works well until the first few days. Then the time step collapses to extremely slow values and the Inlet and Outlet temperatures suddenly decrease of several °C.

I noticed that the virtual radius of the BHE is very large (30 m more or less) while the real radius is 0.08 m. Anyway the mesh discretization is in good agreement with the ideal element size (Delta was computed with the formula suggested in White papers Vol5.). I can also see that the mesh nodes around the BHE are coincident with the Ideal Element Size circle that can be drawn as an attribute of BHE. Furthermore, moving the nodes around the BHE, does not seem to result in variation of the virtual radius.

Do you think that the problem is the big difference in the radii? Any suggestion about ways to solve this issue ?

Thanks you in advance for any help!

Posted Wed, 25 Jul 2018 10:49:12 GMT by Björn Kaiser
You observe a decrease in the time-step size to satisfy the error criteria you adopted. FEFLOW provides a powerful method which supports you to elucidate where the error criteria is spatially violated. This method allows you to identify critical areas with ill-posed model settings.

You can plot the nodal based error by means of predefined distributions of the primary variables you are solving for. If you solve for groundwater flow and for heat transport you can additionally distinguish whether the flow solution or the heat solution is responsible for small time-step sizes.

To activate the distribution, please go to the Data Panel and Add Predefined Distribution for the error norm of interest (e.g. $error_norm).

In this context, please note that you have to activate the predefined distribution in the fem-file (before you start the simulation). This is attributed to the fact that the error norm is calculated while FEFLOW simulates.

After you spatially identified the largest residuals you could have a look on the local settings at this location.

You must be signed in to post in this forum.