Posted Wed, 28 Mar 2007 15:22:10 GMT by Michael
Hi everyone,

I have a really big model with 434 546 elements. When I'm trying to run the model, there is an a pop up window indicated :

Non positive determinant for element = 1947. Obviously, an extremely distorted element geometry as a result of false mesh design an generation.

I really dont know what to do with it . It fact, mesh generation is performed by FEFLOW and it autodetect a problem. How can I do to correct it considering that I have 434 000 elements....


Posted Thu, 29 Mar 2007 07:58:06 GMT by Boris Lyssenko
If the error is not due to an extremely steep layering, the reason is probably an overlap of elements in the superelement mesh. Indeed it is quite difficult to detect the location and fix the problem in the mesh. If you haven't refined the mesh after generation, the element numers are probably relatively ordered, so you might have a chance to find the location using the mesh inspector in 'mesh geometry'. However, it is still difficult to fix. I currently see only two possibilities without having to start from scratch: 1. To export the mesh, fix it in GIS and import the mesh again. However, all parameters have to exported and imported, too. 2. To try to fix the error in the ASCII fem file. Be careful with the latter option as you can mess up your model totally!
Posted Thu, 29 Mar 2007 13:49:43 GMT by Michael
Thanks Peter for your answer. Just another question.

With your answer, I supposed that the problem is caused by an important topographie on the roc body and by really thin layer superposition (8) in this section. Feflow indicate a mesh located in the center of a superelement. Beacause of this, I supposed the problem is not caused by superelement overlap. So, for all layers topography, Feflow must ''adapt '' the mesh in order elimate gap in the layer.

There is rule of tumbs that we should follow in order to eliminate this problem.....because I have to modify the model layers topography ?

Thanks, Michael
Posted Thu, 29 Mar 2007 14:13:39 GMT by Michael

Just another information. I modified my 8 slices to a constant elevation in all the model and I tried to run it. As I supposed, it worked well. It's just confirm the problem. Before to re-arrange my slices profile, I will wait for your advice ....

thanks, Michae;
Posted Mon, 02 Apr 2007 09:08:55 GMT by Boris Lyssenko

please try to keep a minimum thickness for your layer. FEFLOW probably won't handle layer thicknesses of 1e-8 m. However, thicker elements do not solve the problem if your elements are extremely steep. If you put layer elevations with a nearly vertical shape, you'll have angles near 0 and near 180 degrees in your finite elements. That will lead to trouble in any finite element code. In the latter case, please try to smooth your model bottom elevation a little bit.

You must be signed in to post in this forum.