Posted Sun, 15 Jul 2018 08:54:50 GMT by Anner Paldor Student
Hi all,
Just wanted to share something that is probably very important to some of you.
I ran some simulations with both heat and mass transport calculations, and then wanted to compare the results to isothermal simulations. What I did was to simply tske the file of the previous simulation and save it as fem, and then in the problem class settings I unchecked the "heat transfer" option. Everything seemed ok - all the options that are irrelevant for simulations with no heat calculations (e.g. temperature BC etc.) disappeared, as expected. But when I ran the simulation the salt-fresh water interface took a very weird shape - nearly vertical. After a few weeks of deep confusion I found out that the density ratio had been assigned the value that pertained to the thermal expansion, after I turned off the heat calculations. So instead of modeling saltwater with density of 1025 kg/cum (density ratio 0.025) the saltwater in my model was actually nearly as dense as the freshwater (the density ratio was 0.0001 - which is the value of the thermal expansion).

Just wanted to give a heads up to those of you who might encounter this. Hope I can help others avoid the confusion I suffered...

Posted Mon, 16 Jul 2018 08:34:24 GMT by Björn Kaiser
Thanks for sharing Anner. Which Update are you using? Please go on Help and then on About. The number after U is the number I am interested in.
Posted Sun, 29 Jul 2018 06:47:22 GMT by Anner Paldor Student
Hi Bjorn,
Sorry for the late response.
I am using update 11.

Posted Mon, 30 Jul 2018 10:38:34 GMT by Björn Kaiser
Thanks for the note Anner. Bug is reported.

You must be signed in to post in this forum.