Posted Tue, 29 Mar 2022 07:07:45 GMT by Hector Jose Gosalbez Ingeniero Químico
Hi guys,

I am using a MBBR blocks (I know they are “delicate”), and my question is that I need to loose around 1 day of simulation information to reach constant results, despite I am using a constant influent and operational parameters, and I have started the simulation after using the option “From dynamic to dynamic simulation” and having previously reached a constant behaviour in the efluent. Please, see the attached plot of the effluent.

This fact is something without importance in case of using stational simulations, but my next step is using dynamical data, and loosing around 1 day of results matters…..Is there any recommendation to smooth the results of the first day of simulation?

Thanks in advance!


Posted Tue, 29 Mar 2022 08:40:32 GMT by Enrico Remigi WEST Product Owner
Hello Hector,
does your model configuration include a controller, e.g. PI ?
If that's the case, then that may be the issue (I have had the same in multiple occasions).
When you re-initialise a simulation, it transfers the end states of the derived state variables, which is of course generally correct.
It is not correct for the Integ_e variable of a PI controller, that should always be initialised back to zero.

So, if you do have a PI controller, try the following:
- unhide the hidden variables (via the application menu/Options)
- manually reset the initial value for Integ_e to zero

Hope this helps
(btw this is going to be fixed in the next release)
Posted Tue, 29 Mar 2022 09:06:39 GMT by Hector Jose Gosalbez Ingeniero Químico
Thanks Enrico for your response. Yes, I have a PI controller, as you well guessed.

However, despite I have manipulate the value of the “Integ_e” to zero, the result in the effluent is the same. In the attached plot named “Integ_e” you can see how its value starts in zero, but the result is the same…. Maybe have I not applied correctly your suggestion?

Thanks again.

Posted Wed, 30 Mar 2022 18:35:26 GMT by Enrico Remigi WEST Product Owner
Hello Hector,
no it seems to me you did it correctly: I am surprised nothing changes.
Please send your project to our support and we'll investigate further.
Posted Thu, 07 Apr 2022 17:08:07 GMT by Christopher Gaszynski WEST Developer
Hi Héctor,

We have investigated the issue and we had it the wrong way around. The way to solve the error is to comment out Integ_e, so that it does [u]not[/u] initialize to 0.

I hope that this helps  :)

You must be signed in to post in this forum.